Like summary

Discussion in 'Bug Reports' started by RichardKYA, Jan 11, 2016.

  1. RichardKYA

    RichardKYA Active Member

    Clicking "x others" doesn't bring up the members list of those that have liked the event. I have tested with both my custom style and XF default and with both, the result is the same. The only difference is the server error log mentioned here, this only happens due to my edits in which I remove "xen:likes" to display the likes count only, eg:

    Code:
    <span class="LikeText"><a href="{xen:link events/likes, $event}" class="OverlayTrigger">{$event.likes} Likes</a></span>
    To help, here are the error logs that I do receive with my custom style...

    ErrorException: Undefined variable: eventsModel - library/FS/Events/ControllerPublic/Events.php:765
    Generated By: Richard, A moment ago
    Stack Trace
    #0 /home/public_html/members/library/FS/Events/ControllerPublic/Events.php(765): XenForo_Application::handlePhpError(8, 'Undefined varia...', '/home/...', 765, Array)
    #1 /home/public_html/members/library/XenForo/FrontController.php(351): FS_Events_ControllerPublic_Events->actionLikes()
    #2 /home/public_html/members/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #3 /home/public_html/members/index.php(13): XenForo_FrontController->run()
    #4 {main}
    Request State
    array(3) {
    ["url"] => string(234) "members/events/running-routine.1/likes?&_xfRequestUri=%2Fmembers%2Fevents%2Frunning-routine.1%2F&_xfNoRedirect=1&_xfToken=3%2C1452510875%2C24bebf82bbad4f0a246854c3e0ccde1340ee5b4e&_xfResponseType=json"
    ["_GET"] => array(4) {
    ["_xfRequestUri"] => string(34) "/members/events/running-routine.1/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfToken"] => string(53) "3,1452510875,24bebf82bbad4f0a246854c3e0ccde1340ee5b4e"
    ["_xfResponseType"] => string(4) "json"
    }
    ["_POST"] => array(0) {
    }
    }

    ErrorException: Fatal Error: Call to a member function getEventById() on null - library/FS/Events/ControllerPublic/Events.php:765
    Generated By: Richard, 4 minutes ago
    Stack Trace
    #0 [internal function]: XenForo_Application::handleFatalError()
    #1 {main}
    Request State
    array(3) {
    ["url"] => string(234) "/events/running-routine.1/likes?&_xfRequestUri=%2Fmembers%2Fevents%2Frunning-routine.1%2F&_xfNoRedirect=1&_xfToken=3%2C1452510875%2C24bebf82bbad4f0a246854c3e0ccde1340ee5b4e&_xfResponseType=json"
    ["_GET"] => array(4) {
    ["_xfRequestUri"] => string(34) "/members/events/running-routine.1/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfToken"] => string(53) "3,1452510875,24bebf82bbad4f0a246854c3e0ccde1340ee5b4e"
    ["_xfResponseType"] => string(4) "json"
    }
    ["_POST"] => array(0) {
    }
    }
     
  2. RichardKYA

    RichardKYA Active Member

    Reported this 2 and half months ago, any info on this or can anyone else reproduce this and confirm?

    Thank you
     
  3. Jeremy

    Jeremy Administrator Staff Member

    o_O I honestly don't know how this one slipped thru the cracks. I will patch it up and release a fix shortly.
     
    RichardKYA likes this.

Share This Page